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Errata for ArcGIS Desktop 9.2

This document provides errata for people who want to perform the 
exercises in Getting to Know ArcGIS Desktop, Second Edition using ArcGIS 
Desktop version 9.2 software. The errata include changes to the user 
interface and changes to exercise instructions. A few exercises have been 
replaced in their entirety because software changes necessitated extensive 
modifications to exercise steps or workflows.
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General – ArcMap
Tools toolbar

Two new tools:

Go To XY—Allows you to type an x,y location and navigate to it.

Clear Selected Features—Deselects all of the currently selected features in the 
active data frame.

Select By Attributes

Changed dialog: 
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Select By Location

Changed dialog:

Chapter 8: Exercise 8a
Page 200

Click the Selection menu and click Options. 

In the Selection Options dialog, the selection tolerance is set to 5 pixels.

Page 201

In the Selection tolerance box, replace the value of 5 with 0 as shown in the following 
graphic, then click OK.
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Chapter 10: Exercise 10a
Page 257

In the list of layers, check Neighborhoods.

Page 264

In the list of spatial relationships, click the drop-down arrow and click 
“have their centroid in.”

 Chapter 11: Exercise 11d
Page 297

In the Saving Data dialog, make sure the Save as type drop-down list is 
set to File and Personal Geodatabase feature classes.

 Chapter 12: Exercise 12c
Page 327

Right-click on the field name StandValue and click Field Calculator.

Chapter 13
Page 334

Introduction: Last paragraph 

For more information about coordinate systems and map projections, click the Con-
tents tab in ArcGIS Desktop Help and navigate to Mapping and visualization>Using 
ArcMap>Specifying a coordinate system.
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Page 348

Defining a projection: Third paragraph

If ArcMap sees that the coordinate values are big six- or seven-digit numbers, it knows 
that the data is in a projected coordinate system, but again, it doesn’t know which one. 
You’ll get a message similar to this one:

Chapter 13: Exercise 13b
Page 350

In the Add Data dialog, navigate to C:\GTKArcGIS\Chapter13\Data and 
click FastCities.lyr, as shown in the following graphic. Click Add.

ArcMap warns you that the layer is missing spatial reference information.
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Page 352

Click the Input Dataset or Feature Class drop-down arrow and click 
FastCities.lyr.

You see that the layer’s Coordinate System is not filled in (unknown).

Chapter 14
Page 358

Introduction: Last paragraph 

Note: ArcGIS 9.2 introduces an alternative to the personal geodatabase, a new type 
of single-user geodatabase referred to as the file geodatabase. Its advantages include 
improved performance, more efficient storage, and no database size limit.  For more 
information about the new file based geodatabase, click the Contents tab in ArcGIS 
Desktop Help and navigate to ArcGIS Desktop Help Online > Geodatabases and Arc-
SDE > An Overview of the  Geodatabase >Types of geodatabases or What’s new in ArcGIS 
> What’s new in ArcGIS 9.2, then click the link to open the What’s New in ArcGIS 
9.2 PDF.

Chapter 15: Exercise 15b
Page 401

Right-click anywhere on the map display. On the context menu, click 
Direction. In the pop-up box, replace the current value with 73.4, as 
shown in the following graphic, then press Enter.
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Note: If your Direction pop-up box looks different from the one shown on page 401, 
your Direction Type may be set incorrectly. To change the setting, on the Editor tool-
bar, click the Editor menu and click Options. In the Editing Options dialog, click the 
Units tab. Change the Direction Type to Polar. Make sure your settings match those 
shown in the following graphic. 

Chapter 18: Exercise 18a
Page 468

Replace the X Axis Interval value of 10 with 5 and the Y Axis Interval of 
10 with 5, as shown in the following graphic. Click OK, then click OK in 
the Data Frame Properties dialog.

 
Page 472

Click OK in the Display XY Data dialog to display the points on the map. 
Click OK to dimiss the “Table Does Not Have Object-ID Field” warning 
message.

A layer called latlong_etang.txt Events is added to the table of contents. (“Events” is a 
technical term for points created from x,y coordinate values.) 
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Note: If the table on which an XY event layer is based does not have an ObjectID 
field, you get the message box shown above and you won’t be able to perform certain 
tasks on the layer. 

You’ll give the layer a simpler name, then resymbolize the points with a symbol for 
typhoons.

Chapter 20
Page 519

Introduction: Last paragraph 

For more information about spatial modeling and ModelBuilder, click the Contents 
tab in ArcGIS Desktop Help and navigate to Geoprocessing >Automating your work 
with models > Model concepts and terms and Geoprocessing >Automating your work with 
models > Using ModelBuilder.
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Creating graphs
The ArcGIS Graph Wizard lets you create many different kinds of graphs, including 
column, pie, area, and scatter graphs. You can set properties for such elements as titles, 
axes, and graph markers (the bars in a bar graph, for instance). Graphs can be saved 
with a map document or as files with a .grf extension that can be added to any map 
document.

Exercise 11b
You have dissolved the forest stands into lease areas and summed their harvestable 
values. In this exercise, you’ll present the values in a graph and add the graph to a 
map layout.

Start ArcMap. In the ArcMap dialog, click the option to use an existing 
map. In the list of existing maps, double-click Browse for maps. (If Arc-
Map is already running, click the File menu and click Open.) Navigate to 
C:\GTKArcGIS\Chapter11. Click ex11b.mxd and click Open.

The map shows the lease areas you created in the previous exercise.
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Click the Tools menu, point to Graphs, and click Create.

The Create Graph Wizard opens.

In the first panel, you’ll accept the default graph type (Vertical Bar) and the default 
Layer (Leases), and choose the attribute you want to graph.

Click the Value field drop-down arrow and choose SUM_StandValue 
from the list.

You’ll label the x-axis. As you make changes, the graph will update.
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Click the drop-down arrow for X label field and choose LeaseID from 
the list.

 The LeaseID values display on the x-axis.

Uncheck Add to legend. Make sure your dialog matches the following 
graphic.

Click Next.
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In the second panel, you’ll change the default graph title, add a footer, and remove 
the axis titles.

In the Title box under General graph properties, replace Graph of Leases 
with Lease Values. In the Footer box, type In millions of dollars.

In the Axis properties panel (near the bottom of the wizard), make sure 
the Left tab is selected.  Delete Sum_StandValue from the Title box, 
leaving it blank. Make sure Visible is checked.

The left axis values display on the graph but the title “Sum_StandValue” does not. 
You’ll make the same change to the bottom axis.

Click the Bottom tab. In the Title box, delete LeaseId. Make sure Visible 
is checked.

Make sure your dialog matches the following graphic, then click Finish.
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The graph displays in a window that floats on the application window. The graph 
makes it easy to compare the lease area values. Lease F, the most valuable, is worth 
about 1.5 billion dollars.

NOTE: If you resize the graph window, values displayed along the left axis may change.

You’ll add the graph to the map layout.

Right-click on the graph title bar. On the context menu, click Add to 
Layout.

ArcMap switches to layout view.

Close the graph window.
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The graph displays in the middle of the layout page, marked with blue selection 
handles. (Other layout elements, such as the map title and lease labels, have been 
added for you.)

On the Tools toolbar, make sure the Select Elements tool is selected.

Drag the graph to the upper right corner of the layout, as shown in the 
following graphic. Click outside the layout page to unselect the graph.

Close the Layout toolbar.

If you want to save your work, click the File menu and click Save As. Nav-
igate to C:\GTKArcGIS\Chapter11\MyData. Rename the file my_ex11b.
mxd and click Save.

If you are continuing with the next exercise, leave ArcMap open. Oth-
erwise, click the File menu and click Exit. Click No if prompted to save 
your changes.
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Creating feature classes
When you imported data in the previous exercise, you accepted the spatial properties 
of the existing data. When you create a new feature class, you have to define these 
properties yourself. This means specifying the feature class geometry—point, line, or 
polygon—and the spatial reference.

A spatial reference is made up of a coordinate system, a spatial domain, and a preci-
sion. As you learned in chapter 13, a coordinate system is a framework for locating 
features on the earth’s surface using either latitude-longitude or x,y values. A spatial 
domain defines the bounding coordinates for a feature class, beyond which features 
cannot be stored. Precision defines the smallest measurement that can be made in the 
coordinate system. For example, if the coordinate system units are feet, a precision 
of 12 allows you to make measurements as small as an inch. If the coordinate system 
units are kilometers, a precision of 1,000 allows you to make measurements as small 
as a meter.

The task of defining a spatial reference is simplified by the fact that you can select 
from a list of coordinate systems. ArcCatalog will set default domain and precision 
values for you. You can also import the spatial reference from another data set and 
modify it or use it as is.

Exercise 14b
You now know that you can convert the city’s existing spatial data to a geodatabase. 
You also need to know how to create new data in the geodatabase format. In this exer-
cise, you will make a feature class for water lines, although you won’t put any features 
in it until the next chapter.

If you have completed exercise 14a, skip to step 2. Otherwise, start Arc-
Catalog. In the ArcCatalog tree, double-click C:\GTKArcGIS. Double-click 
Chapter14. Double-click Ex14bData. Right-click CityData.mdb and click 
Copy. Right-click MyData and click Paste.

Start ArcCatalog, if necessary. In the ArcCatalog tree, double-click C:\
GTKArcGIS. Double-click Chapter14, then double-click MyData. Right-click 
the CityData personal geodatabase, point to New, then click Feature Class.

1
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The first panel of the New Feature Class wizard opens.

In the Name box, type WaterLines.

 
The default Type is Polygon Features. Since you are creating a feature class of water 
lines, you‘ll change this to Line Features.

3
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Click the Type drop-down arrow and click Line Features.

Click Next.

As no coordinate system has been selected, the Name is unknown and the Name box 
is empty.
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Click Import.

In the Browse for Coordinate System dialog, navigate to C:\GTKArc-
GIS\Chapter14\MyData. Double-click on CityData.mdb and click Parcels. 
Make sure that the dialog matches the following graphic, then click Add.

 
The name of the coordinate system you imported appears in the Name box.
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Click Next.

The XY resolution defines the minimum distance between two coordinates before 
they are considered identical. The maximum and minimum XY values define the 
bounding coordinates for the feature class. You will accept the default values. 

Click Next. 9
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The fourth panel displays the field names, data types, and field properties that belong 
to the new feature class. OBJECTID and SHAPE are required fields, automatically 
added by the software. The OBJECTID field stores a unique ID number for every 
feature in the class. The SHAPE field stores each feature’s shape and location.

Depending on the type of feature class created, ArcGIS also creates and maintains 
measurement fields. A SHAPE_Length field is created for line feature classes. A 
SHAPE_Length and a SHAPE_Area field are created for polygon feature classes. 
(The SHAPE_Length attribute for polygons stores perimeter lengths.) These mea-
surement fields appear only after the feature class is created.

In the Field Name column, click SHAPE. The field properties for the 
SHAPE field are displayed.

Notice that the geometry type is set to Line.

Click Finish.
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In the ArcCatalog tree, if necessary, click the plus sign next to CityData.
mdb.

WaterLines has been added to the list of feature classes.

In the next exercise, you will add two new attributes to the WaterLines feature class: 
one for the date water lines are installed and one for the type of water line.

If you are continuing to the next exercise, leave ArcCatalog open. Oth-
erwise, click the File menu and click Exit.
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Creating an address locator
Geocoding starts with creating an address locator. Address locators come in different 
styles, each appropriate to reference data with different attributes. For example, the 
style called “Single Field” is used with reference data that contains only a single attri-
bute of geographic information. In a reference map of the United States, for instance, 
this would probably be a state name field. The data to be geocoded could be located 
in the correct state, but no more precisely than that.

The address locator style called “ZIP” is used with reference data that has a ZIP Code 
attribute. A table of U.S. addresses could be located within the correct ZIP Codes.

The “US Streets” style is used with street reference data that contains a street name 
attribute and beginning and ending address ranges for each side of a street. A table of 
U.S. addresses could be geocoded to their approximate positions along the length of 
a street and on the correct side of the street.

Each address locator style requires that certain attributes be present in the address 
table as well. For more information about address locator styles, click the Contents 
tab in ArcGIS Desktop Help and navigate to Geocoding and address management > 
Preparing for geocoding > Preparing reference and address data.

Exercise 17a
You work for an online Yellow Pages company that sells advertising—everything from 
listings and banner ads to interactive storefronts. A new service you plan to offer is a 
digital map that displays the location of a client’s business. Your job is not to create 
the Internet map service itself but rather to test the technology for converting cus-
tomer addresses to map points. Being inexperienced with geocoding, you’ll work with 
a small sample of your potential customer base.

Start ArcMap. In the ArcMap dialog, click the option to use an existing 
map. In the list of existing maps, double-click Browse for maps. (If Arc-
Map is already running, click the File menu and click Open.) Navigate to 
C:\GTKArcGIS\Chapter17. Click ex17a.mxd and click Open.

1
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The map shows a portion of downtown Atlanta, Georgia, with layers of streets, inter-
state highways, and ZIP Codes.

At the bottom of the table of contents, click the Source tab.

 
When the Source tab is selected, the table of contents shows nonspatial tables, such 
as dBASE® files, that belong to the map document. In this case, you see a table of 
customers, which contains a sample of your customer database. This is the address 
table you’ll geocode in the next exercise.

The address locator style you choose depends on the attributes in your reference layer 
(the Atlanta streets layer) and in your address table. You’ll open the two tables to look 
at this information.

2
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In the table of contents, right-click the Customers table and click Open.

The attributes include customer ID, name, street address, five-digit ZIP Code, and 
business type. For geocoding, the relevant attributes are ADDRESS and ZIP.

Close the Attributes of Customers table. In the table of contents, right-
click the Atlanta streets layer and click Open Attribute Table.

The four address range attributes are: L_F_ADD (left “from” address), L_T_ADD 
(left “to” address), R_F_ADD (right “from” address), and R_T_ADD (right “to” ad-
dress). These are the beginning and ending street numbers on each side of a street 
segment. 

There are several other address attributes: 

PREFIX is a direction that precedes a street name, like the “N” in 139 N. 
Larchmont Blvd.

PRE_TYPE is a street type that precedes a street name, like “Avenue” in 225 
Avenue D. 

4
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ZIPL and ZIPR are the ZIP Codes for the left and right sides of a street seg-
ment. 

CITYL and CITYR are the city names for the left and right sides of a street 
segment. 

NAME, TYPE, and SUFFIX direction are the familiar attributes of a street 
address. 

The attributes in the Atlanta streets table most closely match the “U.S. Streets with 
Zone” address locator style.

Close the table. On the Standard toolbar, click the ArcCatalog button.

In the catalog tree, navigate to C:\GTKArcGIS\Chapter17\MyData. Right-
click My Data, point to New, and click Address Locator.
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Scroll through the list to US Streets with Zone and click on it.

Click OK.

The new US Streets with Zone Address Locator dialog opens.

You’ve already chosen an address locator; now you’ll specify the reference data that 
will be used with it.

8
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9 In the Name text box, highlight the name New Address Locator and 
type Atlanta customers.

On the Primary table tab, click the Browse button next to the Reference 
data box.

In the Choose Reference Data dialog, navigate to C:\GTKArcGIS\
Chapter17\Ex17aData and click on streets.shp. (Streets.shp is the file 
name of the Atlanta streets layer.) Make sure your dialog matches the 
following graphic, then click Add.

 
The path to the reference data is added to the Reference data box.
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The Fields list shows the types of address information in the reference data that the 
address locator style can use. Required information is boldfaced. The values in the 
corresponding drop-down lists show the reference data attributes that contain this 
information. In each case, ArcGIS has already selected the correct field name. If it 
hadn’t, you could use the drop-down arrows to choose the right fields. 

In the Input Address Fields frame, you specify the fields from the address table (Cus-
tomers) that contain address information.

The box on the left lists the two kinds of input address information required by the 
address locator style: Street (for the street address) and Zone (for the ZIP Code). The 
box on the right lists the field names that, by default, ArcGIS recognizes as contain-
ing this information. 
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In step 3, you saw that the street address information in the Customers table is con-
tained in a field called ADDRESS. Since this is a recognized name, you don’t have to 
do anything. (If your customer street address information was stored in a field with 
an unrecognized name, such as Cust_Addr, you would click Add to include it.)

In the box on the left, click on Zone.

In the Customers table, the zone information is contained in a field called ZIP. Again, 
this is a field name recognized by ArcGIS. (It doesn’t matter whether it’s upper or 
lowercase.) 

You’ll accept the default settings in the rest of the dialog.

Make sure your dialog matches the following graphic, then click OK.

ArcGIS creates the new address locator.
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In the next exercise, you’ll add the Atlanta customers address locator to ArcMap and 
use it to match addresses.

Make sure ArcCatalog is the active application. Click the File menu and 
click Exit.

If you’re continuing with the next exercise, leave ArcMap open. Other-
wise, click the ArcMap File menu and click Exit. Click No when prompted 
to save your changes. 

15

14



Exercise 17b—Errata for ArcGIS 9.2

31   Getting to Know ArcGIS Desktop • Exercise 17b

Matching addresses 
Now that you’ve created an address locator, you can compare the table of addresses to 
the reference data attributes and look for matches. 

The first step in address matching is standardizing the addresses in the address table; 
that is, dividing them into their component parts. This is done by the address locator. 
For example, the address “500 Rankin Street NE” has four parts: the street number 
(500), the street name (Rankin), the street type (Street), and a suffix (NE). The refer-
ence data is already standardized—each address part is a separate attribute. 

ArcGIS takes each standardized address from the address table and looks for features 
in the reference data with matching parts. For each address, it generates a list of prob-
able or possible matching locations, called candidates, in the reference data. Each can-
didate gets a score that rates its likelihood of being the correct location. For ArcGIS to 
make a match and create a point feature, a candidate’s score must reach a certain level. 
You can choose both the score that defines a location as a candidate and the score that 
defines a candidate as a match. By default, the minimum candidate score is 10, on a 
scale of 100, and the minimum match score is 60. 

When ArcGIS has made as many matches as it can, it creates a new data set, which 
has a point feature for each address, whether matched or not. Features that have 
unmatched addresses are not assigned spatial coordinates, and therefore do not dis-
play. You can adjust the geocoding options and try to find matches for unmatched 
addresses. 

Most of the time, geocoding is done from a table of addresses, but as long as you have 
created an address locator, you can also geocode by typing address information into 
the Find dialog. Geocoding this way does not create new features, but will flash a 
matching location on the map or place a graphic there. It’s useful in situations where 
you need to locate a single address or a few addresses quickly—for example, to make 
immediate deliveries. 

Exercise 17b 
Before geocoding your customer table, you’ll test the address locator by locating the 
address of the Ace Market, a downtown Atlanta business.

Start ArcMap. In the ArcMap dialog, click the option to use an existing 
map. In the list of maps, double-click Browse for maps. (If ArcMap is 
already running, click the File menu and click Open.) Navigate to C:\
GTKArcGIS\Chapter17. Click ex17b.mxd and click Open.

1
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The map shows the layers of Atlanta streets, interstate highways, and ZIP Codes. The 
Customers table is at the bottom of the table of contents. (If you don’t see it, click the 
Source tab at the bottom of the table of contents.) 

You’ll add the address locator to the map document.

Click the Tools menu, point to Geocoding, and click Address Locator 
Manager.

Click Add. In the Add Address Locator browser, navigate to C:/GTKArc-
GIS/Chapter17/MyData folder. Click on the Atlanta customers address 
locator. Make sure your dialog matches the following graphic, then click 
Add.
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The name of the address locator and a description of the style appear in the Address 
Locator Manager dialog.

Make sure your dialog matches the following graphic, then click Close.

Now that the address locator has been added to the map document, you can find ad-
dresses on the map.

On the Tools toolbar, click the Find button.
 

4
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In the Find dialog, click the Addresses tab. The Atlanta customers ad-
dress locator should be displayed in the Choose an address locator drop-
down list. If it isn’t, click the drop-down arrow and select it.

In the Street or Intersection box, type 1171 Piedmont Ave NE, the ad-
dress of the Ace Market. Make sure your dialog matches the following 
graphic, then click Find.

One candidate street segment appears at the bottom of the dialog. Its score is 66.

7
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By default, only the candidate with the highest score is displayed. If you wanted, you 
could display additional candidates by checking the Show all candidates check box.

Scroll across the dialog and look at the candidate’s address information.

The address range for odd street numbers, RightFrom and RightTo, is correct because 
it includes the street number 1171. The street name, street type, and suffix directions 
are also correct.

It seems as if the candidate should have scored higher, but, as you may recall from the 
previous exercise, your address locator needs an address and a zone for input. When 
you typed the Ace Market address, you didn’t include its ZIP Code.

In the Find dialog, click in the Zone box and type 30309. Click Find. 

The candidate, listed first, now gets a perfect score. Additional candidates with a score 
of at least 60 are also displayed. You could display candidates with scores below 60 by 
checking the Show all candidates check box.

Click on the first candidate to highlight it. Right-click anywhere on the 
highlighted candidate. On the context menu, click Add Point. Close the 
Find dialog.

9
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ArcGIS places a black dot on the map at the location of the candidate.

Since you geocoded the Ace Market only to make sure that the address loca-
tor was working, you can now delete the graphic.
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On the Tools toolbar, click the Select Elements tool.

Click on the graphic to select it. (Blue selection handles appear.) Press 
the Delete key on your keyboard. 

Now you’ll geocode the customer table.

In the table of contents, with the Source tab still selected, right-click on 
the Customers table and click Geocode Addresses.

In the Choose an address locator to use dialog, the Atlanta customers address locator 
is highlighted.

Click OK to open the Geocode Addresses dialog.
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Geocoding creates a point feature for every address. The points can be saved as a 
shapefile or as a geodatabase feature class. Your Atlanta data is in shapefile format, so 
you’ll save the address points as a shapefile, too.

Click the Browse button next to the Output shapefile or feature class 
box.

In the Saving Data dialog, navigate to C:\GTKArcGIS\Chapter17\MyData. 
Make sure the Save as type drop-down list is set to Shapefile. In the 
Name box, highlight the default name of Geocoding_Result.shp and 
type Geocode1.shp. Make sure that your dialog matches the following 
graphic, then click Save.

 
The Geocode Addresses dialog updates with the new path.
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Make sure your dialog matches the following graphic, then click OK.

 
ArcMap geocodes the addresses and creates the output shapefile. When the process is 
done, the Review/Rematch Addresses dialog displays.
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Of the sixteen addresses in the Customers table, twelve were matched with a score 
from 80 to 100. One was matched with a score less than 80. Three addresses are 
unmatched. You’ll match the unmatched addresses in the next exercise. For now, 
you’ll look at the attributes of the geocoded shapefile.

In the Review/Rematch Addresses dialog, click Done. 

The Geocoding Result: Geocode1 layer is listed at the top of the table of contents. 
There are thirteen point features displayed on the map, representing the locations of 
the matched addresses.

In the table of contents, right-click the Geocoding Result: Geocode1 
layer and click Open Attribute Table.
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The table contains sixteen records, one for each address in the Customers table. The 
Status attribute tells you whether or not each address was matched (M), unmatched 
(U), or tied (T) with another address for the highest score. Point geometry is created 
only for records with the status M. The Score attribute contains the match score and 
the Side attribute tells you whether an address is on the right or left side of the street. 

The next two attributes, ARC_Street and ARC_Zone, contain the information from 
the ADDRESS and ZIP fields in the Customers table. The remaining attributes are 
the same as those in the Customers table. 

Although the ARC_Street and ARC_Zone attributes contain the same values as AD-
DRESS and ZIP, they serve a different purpose. When you rematch unmatched ad-
dresses, you can edit the values in ARC_Street and ARC_Zone to make matches. 
You would do this, for example, if you found mistakes in the Customers table. The 
ADDRESS and ZIP attributes, on the other hand, preserve the original information 
from the Customers table.

Close the table. You have already saved the geocoded shapefile. There 
is no need to save the map document.

If you’re continuing with the next exercise, leave ArcMap open. Other-
wise, click the File menu and click Exit. Click No when prompted to save 
your changes. 
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Rematching addresses 
When you geocode at the street address level, it’s common to have addresses that 
aren’t matched. Occasionally, this is the result of reference data that has errors or is 
incomplete. For instance, an address may belong to a subdivision that is newer than 
the reference data. More often, there is a mistake, such as a spelling error, in the ad-
dress table. In some cases, the problem is with the way ArcGIS has standardized an 
ambiguous address. 

Unmatched addresses can be rematched automatically (ArcGIS does all of them 
at once) or interactively (you do them one at a time). If you rematch automatically, 
you need to adjust the matching options, particularly the minimum match 
score and the spelling sensitivity, or your results won’t change. If you rematch 
interactively, you have additional options. You can edit the way ArcGIS has 
standardized an address and you can match a candidate with a score below the 
minimum match score. 

Exercise 17c 
So far, the address locator has found matches for thirteen addresses in the Customers 
table, leaving three unmatched. In this exercise, you’ll match these three. First, you’ll 
modify the address locator’s settings to generate more candidates. Then you’ll inter-
actively match each address.

Start ArcMap. In the ArcMap dialog, click the option to use an existing 
map. In the list of maps, double-click Browse for maps. (If ArcMap is 
already running, click the File menu and click Open.) Navigate to C:\
GTKArcGIS\Chapter17. Click ex17c.mxd and click Open.
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The map layers include the familiar streets, interstate highways, and ZIP Codes of 
downtown Atlanta. If necessary, click the Source tab at the bottom of the table of 
contents. 

Now you’ll add the layer of geocoded addresses you created in the previous exercise.

On the Standard toolbar, click the Add Data button.

In the Add Data dialog, navigate to C:\GTKArcGIS\Chapter17\MyData. 
Click Geocode1.shp as shown in the following graphic, then click Add.

ArcMap warns you that the layer is missing spatial reference information.

Click OK on the warning message.

The Geocode1 layer is added to the table of contents. It is symbolized with the default 
ArcMap point symbol in a random color. If you like, you can change the symbol 
to make it easier to see. In the following graphics, the point symbol has been set to 
Circle2, Fire Red, 7 points.
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Now you’ll rematch the unmatched addresses.

Click the Tools menu, point to Geocoding, point to Review/Rematch 
Addresses, and click Geocode1. The Review/Rematch Addresses dialog 
opens
.

In the Statistics frame, you see the results from the last exercise. The Rematch Criteria 
frame has options for specifying which addresses you want to rematch. You’ll accept 
the default option of Unmatched addresses. 
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At the bottom of the dialog, click Match Interactively. The Interactive 
Review dialog opens.

The top of the dialog displays the three unmatched records. The first one is 
highlighted in blue. In the middle of the dialog, the Street or Intersection box and 
the Zone box contain the current address information for the highlighted record. 
Edits to this information will be written to the ARC_Street and ARC_Zone fields 
of the Geocode1 table. 
The Standardized address field shows how ArcGIS has divided the address into parts. 
The bottom of the dialog displays match candidates for the highlighted record. There 
are no match candidates for the first record. 

Notice that the ZIP Code for the first record, 30309 is different from the ZIP Codes 
for the other records. It is possible that the wrong ZIP Code was entered in the Cus-
tomers table. You will edit the ZIP Code to see if this produces any candidates.

In the Zone box in the middle of the dialog, highlight the value 30309 and type 
30308. Press Enter.
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Three match candidates appear at the bottom of the dialog. The top candidate has a 
perfect score of 100. 

At the bottom of the dialog, make sure the first candidate is highlighted 
in gray. Click Match. 

The candidate is matched. At the top of the dialog, the record’s Status value changes 
from U to M and its ARC_Zone value changes from 30309 to 30308. (Its ZIP field 
value remains 30309).

Now you’ll match the other two addresses.

At the top of the Interactive Review dialog, click the gray tab to the left 
of the second record to select it.
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There are no match candidates. Notice the odd spelling of the street name, MIRTEL. 
You’ll lower the spelling sensitivity to make it easier to find candidates.

At the bottom of the dialog, click Geocoding Options. The Geocoding 
Options dialog opens.

Drag the Spelling sensitivity slider to 60, as shown in the following 
graphic, then click OK.
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Six match candidates display at the bottom of the Interactive Review dialog. 

The first of the six candidates for 844 MIRTEL ST NE has a score of 73. It has the 
correct address range because 844 falls between the LeftFrom of 806 and the LeftTo 
of 870. The street type, suffix direction, and ZIP Code all match. Only the spelling 
of the street name is different. For the other five candidates with lower scores, the 
address ranges don’t match.

At the bottom of the Interactive Review dialog, click Zoom to: Candi-
dates. Minimize the dialog. The map is zoomed to the extent of the six 
candidates.

The candidate that is highlighted in the dialog is yellow, the other candidates are cyan. 
Common sense suggests that the top candidate is the correct address location and that 
a spelling error was made when this address was entered in the Customers table. 

In the Street or Intersection box, highlight MIRTEL and type MYRTLE . 
Press Enter.
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The scores of the original candidates are adjusted. The top candidate now has a score 
of 100.

At the bottom of the dialog, make sure that the top candidate is high-
lighted in gray. Click Match.

The record’s status changes from U to M and its name is changed in the ARC_Street 
field.

Finally, you’ll match the third address.
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At the top of the Interactive Review dialog, select the third record.

There are no candidates for this record. You could try lowering the spelling sensitivity 
still further, but the problem appears to be something else. It looks like the address, 
42 NORTH NE, has been incorrectly standardized. The street name (NORTH) 
has been interpreted as a prefix direction (N) and the suffix direction (NE) has been 
taken for the street name. The street type (ST or AVE) is missing.

Next to the standardized address, click Modify. The Edit Standardization 
dialog opens.
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In the PreDir box, highlight the value N and press Delete on your key-
board. In the StreetName box, highlight the value NE and type NORTH. 
Click in the SufDir field and type NE. Press Enter.

The Standardized address is updated and 24 candidates appear.

Move the Edit Standardization dialog out of the way so you can see the 
candidates at the bottom of the Interactive Review dialog.  

None of the candidates has a perfect score. This is because all of the candidates have 
a street type (AVE), but there is no street type in the record to be matched. When an 
address component is missing from either the address or the candidate, it isn’t possible 
to get a match score of 100.

It is likely that AVE is the missing street type. You could add AVE to the address by 
typing it in the Street or Intersection box, but instead you’ll simply type it in the Edit 
Standardization dialog.  

In the Edit Standardization dialog, click in the SufType box and type 
AVE. Press Enter. Make sure your dialog matches the following graphic, 
then close the dialog.
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Again, the Standardized address is updated. The top candidate now has a perfect 
match score of 100.

Make sure that the top candidate, with a score of 100, is highlighted. 
Click Match.

The candidate is matched. The record’s status changes from U to M.  Its ARC_Street 
value remains 42 NORTH NE. (Editing the standardization does not update the 
ARC_Street or ARC_Zone fields.)

You’ve matched all the addresses in your customer table.  
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At the bottom of the Interactive Review dialog, click Close to return to 
the Review/Rematch Addresses dialog.

The Statistics frame shows you that fifteen addresses were matched with scores of 80 
or better. One was matched with a score of less than 80.

In the Review/Rematch Addresses dialog, click Done.

On the map there are now sixteen geocoded points.

In the table of contents, right-click the Geocode1 layer and click Zoom 
to Layer. Right-click the layer again and click Label Features.

The points are labeled with the names of your customers’ businesses.
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In the table of contents, right-click the Geocode1 layer and click Open 
Attribute Table.

All the records have the value M in the Status field. Edits that you made during re-
matching (“Mirtel” to “Myrtle” for example) are reflected in the ARC_Street and 
ARC_Zone fields. 

Now that you know how to geocode addresses, the project to offer digital maps as one 
of your company’s advertising services can move forward.

Close the table.

If you want to save your work, click the File menu and click Save As. Nav-
igate to C:\GTKArcGIS\Chapter17\MyData. Rename the file my_ex17c.
mxd and click Save.

If you are continuing to the next chapter, leave ArcMap open. Other-
wise, click the File menu and click Exit. Click No when prompted to save 
your changes.
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Exercise 18b - Errata for ArcGIS Desktop 9.2 sp 4 
 
 
This document provides revised instructions for exercise 18b because the procedures 
documented in the original text book do not work. Also, there is no revision of this 
exercise in the errata published by ESRI for the textbook (GTKAD9.2Updates.pdf): 
from: gis.esri.com/esripress/shared/images/87/GTKAD9.2_Updates.pdf   
 
Chapter 18: Exercise 18b 
Page 471 
Item 5 EXISTING: Close the table. In the table of contents, right-click on 
latlong_etang.txt and click Display XY Data 
 

 
 
Item 5b NEW: Click Edit under the Description window. 
 

 - 1 - 
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Item 5c. Click Import under the XY Coordinate System window.  

 - 2 - 



 
Exercise 18b - Errata for ArcGIS Desktop 9.2 sp 4 
 

 
 
Item 5d. Navigate to the data folder for Exercise 18b. Click City.shp, click Add. Note, 
any of the shapefiles in this folder could have been used, all have identical contents in 
their .prj files. 
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Item 5e. Click OK. 
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Item 5f. Verify your window appears as in the figure above. Then continue with Item 6 
on page 472 in the text book, i.e., “Click OK ...”  
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Starting a model 
ModelBuilder is not a free-standing software application like ArcMap or ArcCatalog, 
but it’s more than just a geoprocessing tool: it’s a design environment for creating 
workflow diagrams called models. Like tools, however, models are stored in a toolbox. 
In earlier chapters, you used some of the tools and toolboxes that come with ArcMap. 
In this exercise, you will learn how to create a new toolbox and put a model inside it.

A new toolbox can be created in ArcToolbox, or in an ordinary file folder, or in a 
geodatabase. Since models are stored in toolboxes, these are also the three locations 
in which models can be created.

The ModelBuilder window has its own menu and toolbar. Many of the controls have 
the same icons and functions as ArcMap controls.

Model

User-created toolbox

User-created toolbox

Model

Geodatabase

Model

User-created toolbox

Folder

Main 
menu

Display

Toolbar



Exercise 20a

Getting to Know ArcGIS Desktop • Exercise 20a56

Exercise 20a 
In the next three exercises, you will create a model of the harvest profitability analysis 
from chapter 12. (The data preparation you did in chapter 11 is assumed to be com-
plete, although you could include those operations in your model as well.) 

The logic of the analysis is not repeated in detail here. If you feel unsure about the 
order of the steps or the reasons behind them, you can refer back to chapter 12. The 
focus of this chapter is mainly on how to diagram the analysis in ModelBuilder.

In this exercise, you’ll make a new toolbox to store your model. Then you’ll create a 
model and add one process to it.

Start ArcCatalog. In the catalog tree, navigate to C:\GTKArcGIS\Chap-
ter20 \MyToolboxes. Right-click on MyToolboxes, point to New, and 
click Toolbox.

A new toolbox is added with its default name highlighted.

In the catalog display, change the new toolbox name to Harvest Models 
and press Enter. In the catalog tree, expand the MyToolboxes folder if 
necessary.
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You have created a toolbox in an ordinary file folder. If you look at the toolbox with a 
file browser, such as Windows Explorer, it appears with a .tbx extension.

Now you will create a model within the toolbox.

In the ArcCatalog tree, right-click the Harvest Models toolbox, point to 
New, and click Model. 

The model window opens. You’ll change the name in the title bar to something more 
meaningful.
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In ModelBuilder, click the Model menu and click Model Properties. In 
the Model Properties dialog, the General tab is selected. In the Name 
box, replace Model with HarvestProfitability (the model name cannot 
contain any spaces). In the Label box, replace Model with Harvest Prof-
itability (the model label may contain spaces). Make sure the dialog 
matches the following graphic, then click OK.

Now you will save and close the model so you can work with it in ArcMap.

On the ModelBuilder toolbar, click the Save button.

Click the Model menu and click Close.
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In the ArcCatalog tree, click the plus sign next to the Harvest Models 
toolbox.

 
The new toolbox is not automatically added to new ArcMap documents. To work 
with the Harvest Profitability model, you must first add the Harvest Models toolbox 
to ArcToolbox from within ArcMap.

In the catalog tree, double-click ex20a.mxd to launch ArcMap and open 
the map document. (If ArcMap is already running, click the File menu 
and click Open. Navigate to C:\GTKArcGIS\Chapter20. Click ex20a.mxd 
and click Open.) 

 
The map contains layers for lease F, goshawk nests, and streams. It should look famil-
iar as it has the same data and symbology as ex12a.mxd.

Now you will open the ArcToolbox window and add the Harvest Models toolbox to it.
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On the Standard toolbar, click the Show/Hide ArcToolbox Window but-
ton to open ArcToolbox. 
 
Position ArcMap and ArcCatalog so that the ArcToolbox window and 
the catalog tree don’t overlap. Make ArcCatalog the active application. 
In the catalog tree, click the Harvest Models toolbox and drag it to the 
bottom of the ArcToolbox window.

 
The Harvest Models toolbox is automatically put in alphabetical order with the other 
toolboxes.

Make ArcCatalog the active application. Click the File menu and click 
Exit.

In ArcMap, in the ArcToolbox window, click the plus sign next to Har-
vest Models to expand it. Right-click the Harvest Profitability model and 
click Edit. When the ModelBuilder window opens, move it so that it 
doesn’t overlap either the ArcToolbox window or the ArcMap table of 
contents.
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Now you will create a process to buffer the goshawk nests. You will drag and drop the 
Buffer tool from ArcToolbox and the NestsF layer from the ArcMap table of contents.

In the ArcToolbox window, click the plus sign next to Analysis tools, then 
click the plus sign next to Proximity.

Click the Buffer tool and drag it to ModelBuilder. Drop it in the center 
of the ModelBuilder window.

The Buffer tool, represented by a rectangle, is added to the model. An arrow connects 
the tool to its output data, represented by an oval. Blue selection handles indicate that 
the elements are currently selected. The fact that they are not colored in means that 
they are incomplete—they are waiting for input data to be attached.
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In the ArcMap table of contents, click the NestsF layer. Drag it to the 
ModelBuilder window and drop it directly on top of the Buffer tool 
rectangle.

 
The NestsF layer, represented by an oval, is automatically connected to the tool it was 
dropped onto. 

Before running the process, you will change the tool and output data settings.

In the model, double-click the Buffer tool rectangle.

 
The Buffer dialog opens—exactly as if you had double-clicked the Buffer tool in Arc-
Toolbox. You will fill in the tool’s parameters just as you did in chapter 12.

By default, the output feature class is set to the Tongass.mdb file in the chapter 20 
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Data folder. To keep the model data separate from the book’s exercise data, you will 
change the output location to the MyData folder.

Click the Browse button next to the Output Feature Class box. In the 
Output Feature Class dialog, navigate to C:\GTKArcGIS\Chapter20\My-
Data and double-click on MyTongass.mdb.

In the Name box, type NestBuf, then click Save.

The output feature class information is updated in the Buffer dialog.

For the buffer distance, make sure the Linear unit option is selected. In 
the Linear unit box, type 800.

The distance units are correctly set to meters. Trees cannot be harvested within 800 
meters of a goshawk nest.

Click the Dissolve Type drop-down arrow and click All.

Overlapping buffer polygons will be dissolved to make a single feature.

Make sure the dialog matches the following graphic, then click OK to 
close the tool.

 
Clicking OK here does not run the tool, it just closes the dialog. In ModelBuilder, 
you can double-click a tool whenever you like to view or change its parameters.
The elements are colored in now, which means that the process is ready to run. 
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When you run the process, a new feature class will be created and saved to disk. The 
output data is not automatically added as a layer to ArcMap, however. If you want the 
data added to the map, you have to set a property on the output data element.

In the model, right-click on the NestBuf oval and click Add To Display to 
check it on.

On the ModelBuilder toolbar, click the Run button to run the model.

 
As a model runs, each of its tools turns red. Your model has only one tool, so if you 
weren’t watching closely (or if the progress report covered the model), you may not 
have seen it. When the tool is finished, it turns yellow again.
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Click Close to close the progress report.

 
The NestBuf layer is added to ArcMap. (You may need to move the ModelBuilder 
window to see it.) 

In ModelBuilder, drop shadows behind the tool and output data elements indicate 
that the process has been run. Once a process has been run, it does not run again un-
less you change a parameter, or choose Run Entire Model or Validate Entire Model 
from the Model menu.

On the ModelBuilder toolbar, click the Save button to save the model.

Click the Model menu and click Close to close the model. In ArcMap, 
close the ArcToolbox window.

The model and all its settings are stored in the Harvest Models.tbx file you created 
at the beginning of this exercise. There is no need to save changes to the map docu-
ment.
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If you are continuing with the next exercise, leave ArcMap open. Oth-
erwise, click the File menu and click Exit. Click No if prompted to save 
your changes.
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